Sửa lỗi giúp mình với



  • Mình cài đặt mấy ngày hôm nay:
    Vấn đề như này mình cài yeoman và generator-angular-fullstack nó chạy bình thường
    Nhưng đến khi chạy: yo angular-fullstack
    Thì báo lỗi , có ai biết phần này không giúp mình với , thanks



  • Bạn đọc lại câu hỏi của mình xem có thiếu gì k ?



  • Bạn nào cài nodejs thì sẽ có thêm trong
    Cmd ( windows) npm
    Mình gõ npm i -g yo generator-angular-fullstack . hoạt động bình thường nhưng đến lúc chạy lệnh yo angular-fullstack
    Thì cứ báo lỗi
    Mình thử với rất nhiều version nodejs vẫn lỗi . bạn test hộ mình với



  • @huong-huoh cài Linux mà chiến nodejs bác nhế. E nói thật là mấy cái thư viện của Node nó ko thích anh Bill đâu. Và nhân tiện, e đề nghị thêm cả là bác viết bài phải có dấu chấm, dấu phảy và xuống dòng và format bài cho hợp lý cái. Đọc bài và cmt của bác mà e Thấy Rõ Nhức Mắt



  • Chào các bác .! Sorry các bác nhiều .Vì em đăng bài bằng điện thoại nên nhiều lúc lỗi font chữ . Mà em cũng test trên Ubuntu vẫn không chạy được :((( . Có ai test hộ em mấy lệnh ấy được không ? . Là lỗi của máy em hay lỗi của thư viện vậy :?



  • Các câu lệnh lần lượt là :
    npm i -g yo gulp bower
    npm i -g generator-angular-fullstack
    yo angular-fullstack #tên project#



  • @huong-huoh

    không lỗi gì cả. Bạn copy "cái lỗi" lên đây để mng giúp, nói xuông là lỗi thì biết ở đâu mà giúp bạn.



  • Em bj lỗi như này này:

    npm ERR! Windows_NT 10.0.15063
    npm ERR! argv "C:\Program Files\nodejs\node.exe" "C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js" "install"
    npm ERR! node v6.11.1
    npm ERR! npm v3.10.10
    npm ERR! code ELIFECYCLE

    npm ERR! [email protected] install: node-pre-gyp install --fallback-to-build
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the [email protected] install script 'node-pre-gyp install --fallback-to-build'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the node-zopfli package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! node-pre-gyp install --fallback-to-build
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR! npm bugs node-zopfli
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR! npm owner ls node-zopfli
    npm ERR! There is likely additional logging output above.

    npm ERR! Please include the following file with any support request:
    npm ERR! C:\Users\Luxury\Desktop\angular-fullstack\npm-debug.log



    1. có thể là do permision của window, bạn Run as administrator của sổ lệnh nhé(nếu muốn sử dụng npm cho cả user thường thì bạn cần set biến môi trường).
    2. Bạn đã cài npm chưa: npm install -g [email protected]
      kiểm tra version của node và npm xem hiện tại là gì: node -vnpm -v
      xóa cache: npm cache clean rồi cài lại những cái trên: npm i -g yo generator-angular-fullstack


  • Em bị lỗi ở lệnh :
    yo angular-fullstack



  • nhớ kiểm tra node-gyp đã có chưa



  • em cảm ơn các bác rất nhiều . nếu bác nào install được cho em download với được không ạ .? tải lên google drive hộ em nhé .Thanks


Log in to reply